Image Image Image Image Image Image Image Image Image Image

 iOSMac | 11/12/2016

Scroll to top

Top

No Comments

Pangu informa sobre vulnerabilidades en iOS 8.4.1

Pangu informa sobre vulnerabilidades en iOS 8.4.1
César
  • On 09/09/2014
  • http://zipzeppelin.com

El equipo de Pangu ha publicado un informe en su blog oficial en el que informa de serias vulnerabilidades en el núcleo del último iOS publicado por Apple.

El post titulado Vulnerabilidades del núcleo de iOS 8.4.1 en AppleHDQGasGaugeControl, nos indica tres errores que han encontrado en el iOS 8.4.1, el último firmware para los dispositivos de Apple y predecesor del esperado iOS 9.

Por un lado informa de un error de desbordamiento de pila, por otro lado un error de acceso a memoria fuera de límite y, por último, uno de desbordamiento de heap.

windknoun

Desde el equipo de Pangu, en concreto Windknown, aseguran que el código de com.apple.driver.AppleHDQGasGaugeControl es muy malo. Sólo el error encontrado de desbordamiento de heap les permite acabar con todas las migraciones de núcleo y hacerse con la ejecución de código en el kernel (el propio núcleo del firmware)

El equipo de Pangu ha publicado un informe en su blog oficial en el que informa de serias vulnerabilidades en el núcleo del último iOS publicado por Apple

Al parecer desde Apple ya tienen solventados estos errores y solucionado el problema con estas vulnerabilidades para su casi ya publicado iOS 9. Quizá sea porque Windknown, del equipo de Pangu, ha hecho un buen trabajo en su informe explicando perfectamente los errores encontrados, haciéndolo de muy fácil lectura y comprensión asta para usuarios que no sean hackers.

A pesar de este informe esperamos que se guarden un as en la manga para conseguir hacer el Jailbreak a iOS 9, aunque desde Apple solucionen este tipo de vulnerabilidades y errores en su nuevo firmware.

TE RECOMENDAMOS:   Apple confirmó nuevos lugares y fechas de salida del iPhone 7